summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-11-09 19:37:58 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:44 +0200
commitd753e826fcf7d87c4e3570658300bcfa750c2940 (patch)
tree2edabfac8f7edbd1b8071c3d929625c9d0384923 /gnu/packages
parent2700ed8ee62d3872538d6ed83c65c566e9782a09 (diff)
downloadguix-d753e826fcf7d87c4e3570658300bcfa750c2940.tar.gz
gnu: Add rust-gix-hash-0.13.
* gnu/packages/crates-io.scm (rust-gix-hash-0.13): New variable.
(rust-gix-hash-0.11): Inherit from rust-gix-hash-0.13.

Change-Id: I4d7e4a048efb463a019d01529622ad96c3a615d5
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 27 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b15c1e5d9a..d040c25955 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30831,8 +30831,34 @@ compile-time feature flags.")
 matching.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-gix-hash-0.13
+  (package
+    (name "rust-gix-hash")
+    (version "0.13.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gix-hash" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0q6c3jjp6q17w7879lwi7r1xw2zr489yk75yq4bm51x03sscg10q"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-document-features" ,rust-document-features-0.2)
+                       ("rust-faster-hex" ,rust-faster-hex-0.8)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/Byron/gitoxide")
+    (synopsis
+     "Borrowed and owned git hash digests used to identify git objects")
+    (description
+     "Borrowed and owned git hash digests used to identify git objects.  This
+package is part of Gitoxide, a pure Rust implementation of Git.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gix-hash-0.11
   (package
+    (inherit rust-gix-hash-0.13)
     (name "rust-gix-hash")
     (version "0.11.4")
     (source
@@ -30842,19 +30868,12 @@ matching.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "0bq986grpsfc6ddav5dlb8zvz1aky264dnnnmax2h1lsmpr2yhjb"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-document-features" ,rust-document-features-0.2)
         ("rust-hex" ,rust-hex-0.4)
         ("rust-serde" ,rust-serde-1)
-        ("rust-thiserror" ,rust-thiserror-1))))
-    (home-page "https://github.com/Byron/gitoxide")
-    (synopsis
-     "Borrowed and owned git hash digests used to identify git objects")
-    (description
-     "Borrowed and owned git hash digests used to identify git objects.")
-    (license (list license:expat license:asl2.0))))
+        ("rust-thiserror" ,rust-thiserror-1))))))
 
 (define-public rust-gix-hashtable-0.2
   (package