summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:26:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:11 +0200
commitda0b9e4f92bf3734c137bcb915b64bc35b46d92a (patch)
tree20c39da7db1350a44dc8ebdca4c3c4df4acc0157 /gnu/packages
parenta8308aa4187b03c4db05a8558b1840f6953b3f50 (diff)
downloadguix-da0b9e4f92bf3734c137bcb915b64bc35b46d92a.tar.gz
gnu: Add texlive-blopentype.
* gnu/packages/tex.scm (texlive-blopentype): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f597b36c9f..f0a3951026 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4498,6 +4498,26 @@ diagrams and bond graphs. While the task is not itself difficult to program,
 it is felt that many users will be happy to have a library for the job.")
     (license license:lppl)))
 
+(define-public texlive-blopentype
+  (package
+    (name "texlive-blopentype")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/luatex/blopentype/"
+                   "tex/luatex/blopentype/")
+             (base32
+              "1zz19a0glxad0bq8kpa2qlrmgysdlda1hpxacf3m42m9n3byrb75")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-gates texlive-texapi texlive-yax))
+    (home-page "https://ctan.org/pkg/blopentype")
+    (synopsis "Basic LuaTeX OpenType handler")
+    (description
+     "This is a basic LuaTeX OpenType handler, based on Paul Isambert's PiTeX
+code.")
+    (license (list license:lppl1.3c license:expat))))
+
 (define-public texlive-bookcover
   (package
     (name "texlive-bookcover")