summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-15 22:50:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-15 23:06:15 +0100
commitddde736722f73ff92b3ea691ab95d14ddf6ed138 (patch)
tree6aac32b45615735529f5be77f1bb2aa3fe42cbec /gnu/packages
parent12ae026e51c8b031a413de2c9b483e68f1efaac0 (diff)
downloadguix-ddde736722f73ff92b3ea691ab95d14ddf6ed138.tar.gz
gnu: Add python-docspec.
* gnu/packages/python-xyz.scm (python-docspec): New variable.

Change-Id: I3103bde3483273a335156b38de742f493fd366f1
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61958d5eac..58a1a2b3cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -622,6 +622,31 @@ Python dataclasses.")
 from JSON payloads using the @code{databind.core} framework.")
     (license license:expat)))
 
+(define-public python-docspec
+  (package
+    (name "python-docspec")
+    (version "2.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "docspec" version))
+       (sha256
+        (base32 "1zqmdrc6k8pprra8p3wpzq2ml2gph1cfjmsyg07f8b8fvizffm28"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #false))  ;there are none
+    (propagated-inputs
+     (list python-databind-core
+           python-databind-json
+           python-deprecated))
+    (native-inputs
+     (list python-poetry-core))
+    (home-page "https://github.com/NiklasRosenstein/python-docspec")
+    (synopsis "Represent API documentation of programming languages")
+    (description
+     "Docspec is a JSON object specification for representing API
+documentation of programming languages.")
+    (license license:expat)))
+
 (define-public python-fire
   (package
     (name "python-fire")