summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-03 23:12:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-04 00:30:56 +0100
commitdf116a89f95954d4ce0508b86f193e0e0494a240 (patch)
tree7203478ad62d66ba88f71d598b062896975d3d39 /gnu/packages
parent5c08ed09397ac01c29100c3c2a879de089f92f6f (diff)
downloadguix-df116a89f95954d4ce0508b86f193e0e0494a240.tar.gz
gnu: synfigstudio: Use gexp.
* gnu/packages/animation.scm (synfigstudio)[arguments]: Use gexp.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/animation.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index e1a5ba3de1..e2a546b5fc 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -23,6 +23,7 @@
 (define-module (gnu packages animation)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
@@ -185,17 +186,16 @@ for tweening, preventing the need to hand-draw each frame.")
                   #t))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; This fixes the file chooser crash that happens with GTK 3.
-         (add-after 'install 'wrap-program
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (gtk (assoc-ref inputs "gtk+"))
-                    (gtk-share (string-append gtk "/share")))
-               (wrap-program (string-append out "/bin/synfigstudio")
-                 `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))
-               #t))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; This fixes the file chooser crash that happens with GTK 3.
+          (add-after 'install 'wrap-program
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let* ((gtk (assoc-ref inputs "gtk+"))
+                     (gtk-share (string-append gtk "/share")))
+                (wrap-program (string-append #$output "/bin/synfigstudio")
+                  `("XDG_DATA_DIRS" ":" prefix (,gtk-share)))))))))
     (inputs
      (list gtkmm-3 gtk+ libsigc++ synfig))
     (native-inputs