summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-05-15 19:58:05 -0400
committerLeo Famulari <leo@famulari.name>2016-05-16 14:52:34 -0400
commitdffded6211313e9ebe9fb853a502c60aa6ccd90c (patch)
tree936b42c6dcb4816172622233e730c3e0a72045e7 /gnu/packages
parent1d30d554b5389eb53eaa1ef7efb07772d0383510 (diff)
downloadguix-dffded6211313e9ebe9fb853a502c60aa6ccd90c.tar.gz
gnu: libtasn1: Update to 4.8.
* gnu/packages/tls.scm (libtasn1): Update to 4.8.
[replacement]: Remove field.
(libtasn1/fixed): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tls.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 92c1263808..8ec8e603a9 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -47,7 +47,7 @@
 (define-public libtasn1
   (package
     (name "libtasn1")
-    (version "4.7")
+    (version "4.8")
     (source
      (origin
       (method url-fetch)
@@ -55,7 +55,7 @@
                           version ".tar.gz"))
       (sha256
        (base32
-        "1j8iixynchziw1y39lnibyl5h81m4p78w3i4f28q2vgwjgf801x4"))))
+        "04y5m29pqmvkfdbppmsdifyx89v8xclxzklpfc7a1fkr9p4jz07s"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)))
     (home-page "http://www.gnu.org/software/libtasn1/")
@@ -65,22 +65,8 @@
 for transmitting machine-neutral encodings of data objects in computer
 networking, allowing for formal validation of data according to some
 specifications.")
-    (replacement libtasn1/fixed)
     (license license:lgpl2.0+)))
 
-(define libtasn1/fixed                            ;for CVE-2016-4008
-  (package
-    (inherit libtasn1)
-    (source
-     (let ((version "4.8"))
-       (origin
-         (method url-fetch)
-         (uri (string-append "mirror://gnu/libtasn1/libtasn1-"
-                             version ".tar.gz"))
-         (sha256
-          (base32
-           "04y5m29pqmvkfdbppmsdifyx89v8xclxzklpfc7a1fkr9p4jz07s")))))))
-
 (define-public p11-kit
   (package
     (name "p11-kit")