summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-02 21:57:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-02 22:02:22 +0100
commite07f60274ba015fc119784ef6cca6258e9b4104f (patch)
treec0105089d7901212ead4f83fb22e907a22e6d84f /gnu/packages
parent5058090ed4b6f4a9d09d74d9516295afff75ece5 (diff)
downloadguix-e07f60274ba015fc119784ef6cca6258e9b4104f.tar.gz
gnu: Add python-confuse.
* gnu/packages/python-xyz.scm (python-confuse): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9cf9fe8c17..12f8dc40da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23555,6 +23555,28 @@ Qt applications.")
  of binary data.")
     (license license:expat)))
 
+(define-public python-confuse
+  (package
+    (name "python-confuse")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "confuse" version))
+       (sha256
+        (base32
+         "0r74djc8r6lfx6ldsqnhpvfsn256gsfzbl33qcm77hp2qr8h9z4j"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pathlib" ,python-pathlib)
+       ("python-pyyaml" ,python-pyyaml)))
+    (home-page "https://github.com/beetbox/confuse")
+    (synopsis "Painless YAML configuration.")
+    (description "Confuse is a configuration library for Python that uses
+YAML.  It takes care of defaults, overrides, type checking, command-line
+integration, human-readable errors, and standard OS-specific locations.")
+    (license license:expat)))
+
 (define-public python-pivy
   (package
     (name "python-pivy")