summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:27 +0200
commite0f8188975b0ba2a14973ca02adb34207674ebed (patch)
treec8746b653f4546c17e0995321f5e240dc38ad557 /gnu/packages
parentba56666e21e4f3a8cbc06a077353ba424b2691be (diff)
downloadguix-e0f8188975b0ba2a14973ca02adb34207674ebed.tar.gz
gnu: Add texlive-pythonimmediate.
* gnu/packages/tex.scm (texlive-pythonimmediate): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 723f916cc0..127faa3301 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93295,6 +93295,39 @@ systems, wikis or other applications that need to prettify source code.")
 script's output in the document.")
     (license license:gpl3+)))
 
+(define-public texlive-pythonimmediate
+  (package
+    (name "texlive-pythonimmediate")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pythonimmediate/"
+                   "tex/latex/pythonimmediate/")
+             (base32
+              "0qdmb155k34g5mml04a8rwwgq9m4s984cjd732zx34hbbqd5rvzr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-currfile texlive-l3packages
+                             texlive-precattl texlive-saveenv))
+    (home-page "https://ctan.org/pkg/pythonimmediate")
+    (synopsis "Library to run Python code")
+    (description
+     "This is a library to run Python code.  Just like PerlTeX or PyLuaTeX,
+this only requires a single run, and variables are persistent throughout the
+run.  Unlike PerlTeX or PyLuaTeX, there is no restriction on compiler or
+script required to run the code.
+
+There are also debugging functionalities: TeX errors result in Python
+traceback, and Python errors result in TeX traceback.  Errors in code executed
+with the @code{pycode} environment give the correct traceback point to the
+Python line of code in the TeX file.  For advanced users, this package allows
+the user to manipulate the TeX state directly from within Python, so you don't
+need to write a single line of TeX code.
+
+In addition to this LaTeX package you need the Python
+@code{pythonimmediate-tex} package.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar