summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-04 15:11:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-04 15:11:04 +0100
commite128839a9481549ed2ba06049fe0769dd78d24a0 (patch)
tree6e2825bfc2037813c994fd1d4efdec7c62e52d72 /gnu/packages
parent114eb987cb0d636361a1957ef285159c9e13a2a5 (diff)
downloadguix-e128839a9481549ed2ba06049fe0769dd78d24a0.tar.gz
gnu: prank: Remove trailing #T.
* gnu/packages/bioinformatics.scm (prank)[arguments]: Remove trailing #T from
build phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 979d26bed2..913300321a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5779,15 +5779,13 @@ generated using the PacBio Iso-Seq protocol.")
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'enter-src-dir
-            (lambda _
-              (chdir "src")
-              #t))
+           (lambda _ (chdir "src")))
          (add-after 'unpack 'remove-m64-flag
            ;; Prank will build with the correct 'bit-ness' without this flag
            ;; and this allows building on 32-bit machines.
-           (lambda _ (substitute* "src/Makefile"
-                                  (("-m64") ""))
-             #t))
+           (lambda _
+             (substitute* "src/Makefile"
+               (("-m64") ""))))
          (delete 'configure)
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
@@ -5801,8 +5799,7 @@ generated using the PacBio Iso-Seq protocol.")
                (install-file "prank" bin)
                (wrap-program (string-append bin "/prank")
                  `("PATH" ":" prefix (,path)))
-               (install-file "prank.1" man))
-             #t)))))
+               (install-file "prank.1" man)))))))
     (inputs
      `(("mafft" ,mafft)
        ("exonerate" ,exonerate)