summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-03 10:39:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-03 10:43:08 +0200
commite19a9eda25e8a03fa2159927f405031651f750e1 (patch)
tree7d809e8c0005027cf2afa490c74b65c378823109 /gnu/packages
parent419315d4e6445c97a2578df4fbaa2e7594e11cf0 (diff)
downloadguix-e19a9eda25e8a03fa2159927f405031651f750e1.tar.gz
gnu: Add r-rapiserialize.
* gnu/packages/cran.scm (r-rapiserialize): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fb6c28faa6..bbedaa2864 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30012,3 +30012,27 @@ the @code{raster} package that is suitable for extracting raster values using
      "This package provides an extendable, performant and multithreaded
 @code{alt-string} implementation backed by C++ vectors and strings.")
     (license license:gpl3)))
+
+(define-public r-rapiserialize
+  (package
+    (name "r-rapiserialize")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RApiSerialize" version))
+       (sha256
+        (base32
+         "0gm2j8kh40imhncwwx1sx9kmraaxcxycvgwls53lcyy2ap344k9j"))))
+    (properties `((upstream-name . "RApiSerialize")))
+    (build-system r-build-system)
+    (home-page
+     "https://cran.r-project.org/package=RApiSerialize")
+    (synopsis "R API serialization")
+    (description
+     "This package provides other packages with access to the internal R
+serialization code.  Access to this code is provided at the C function level
+by using the registration of native function mechanism.  Client packages
+simply include a single header file RApiSerializeAPI.h provided by this
+package.")
+    (license license:gpl2+)))