summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:55:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:23 +0200
commite2807eddc5d016491422a81cccde041bdd971b0e (patch)
tree3d89a7425c5a932580b22e223e37f0859c78d957 /gnu/packages
parentc7d9f162a12082921e60c1c37018cc0d94881119 (diff)
downloadguix-e2807eddc5d016491422a81cccde041bdd971b0e.tar.gz
gnu: Add texlive-scheme-small.
* gnu/packages/tex.scm (texlive-scheme-small): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56dfd0acb1..aeb7c5ccfa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -917,6 +917,55 @@ Live infrastructure.  This scheme corresponds exactly to
 @code{collection-basic}.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-scheme-small
+  (package
+    (name "texlive-scheme-small")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-babel-basque
+           texlive-babel-czech
+           texlive-babel-danish
+           texlive-babel-dutch
+           texlive-babel-english
+           texlive-babel-finnish
+           texlive-babel-french
+           texlive-babel-german
+           texlive-babel-hungarian
+           texlive-babel-italian
+           texlive-babel-norsk
+           texlive-babel-polish
+           texlive-babel-portuges
+           texlive-babel-spanish
+           texlive-babel-swedish
+           texlive-collection-basic
+           texlive-collection-latex
+           texlive-collection-latexrecommended
+           texlive-collection-metapost
+           texlive-collection-xetex
+           texlive-ec
+           texlive-eurosym
+           texlive-hyphen-complete
+           texlive-lm
+           texlive-lualibs
+           texlive-luaotfload
+           texlive-luatexbase
+           texlive-revtex
+           texlive-synctex
+           texlive-times
+           texlive-tipa
+           texlive-ulem
+           texlive-upquote
+           texlive-zapfding))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Small scheme (basic, XeTeX, Metapost, and a few languages)")
+    (description
+     "This is a small TeX Live scheme, corresponding to MacTeX's BasicTeX
+variant.  It adds XeTeX, MetaPost, and some recommended packages to
+@code{scheme-basic}.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
 ;; This package must be located before any package adding it to its native
 ;; inputs.