summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-20 12:39:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-20 12:39:21 +0200
commite2ab228b46a879a3147d8f40d4d98d8ebb278b6b (patch)
tree5d19f3c36ec11974b088b46bfee0296e302063d4 /gnu/packages
parent197ebc36be1dd44f90bcfbbaddda8632cdeff3d2 (diff)
downloadguix-e2ab228b46a879a3147d8f40d4d98d8ebb278b6b.tar.gz
Revert "gnu: Add libgd."
This reverts commit 059e4c9a15b52f7e4b262e3317eac238bf53103d.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/image.scm53
1 files changed, 0 insertions, 53 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1f6327a762..f9709e2b19 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -23,7 +23,6 @@
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1649,55 +1648,3 @@ identical visual appearance.")
 to the standard output.  It works well together with grim.")
    ;; MIT license.
    (license license:expat)))
-
-(define-public libgd
-  (package
-    (name "libgd")
-    (version "2.2.5")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/libgd/libgd.git")
-                    (commit (string-append "gd-" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "17p0dlmn9kigr5b7vgpcsq2323mrgv0rh69x4ysg8nrjl8n5l1nl"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:configure-flags
-       (list "-DBUILD_TEST=1"
-             "-DENABLE_FONTCONFIG=1"
-             "-DENABLE_FREETYPE=1"
-             "-DENABLE_JPEG=1"
-             "-DENABLE_PNG=1"
-             "-DENABLE_WEBP=1"
-             "-DENABLE_XPM=1"
-             (string-append "-DFREETYPE_INCLUDE_DIRS="
-                            (assoc-ref %build-inputs "freetype")
-                            "/include/freetype2"))))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (inputs
-     `(("fontconfig" ,fontconfig)
-       ("freetype" ,freetype)
-       ("libjpeg" ,libjpeg)
-       ("libpng" ,libpng)
-       ("libwebp" ,libwebp)
-       ("libxmp" ,libxpm)
-       ("zlib" ,zlib)))
-    (home-page "https://libgd.github.io/")
-    (synopsis "GD Graphics Library")
-    (description "gd is a graphics library.  It allows your code to
-quickly draw images complete with lines, arcs, text, multiple colors,
-cut and paste from other images, and flood fills, and write out the
-result as a PNG or JPEG file.  This is particularly useful in World
-Wide Web applications, where PNG and JPEG are two of the formats
-accepted for inline images by most browsers.")
-    ;; The project is released under a free license, which require
-    ;; that its terms are present in "user-accessible supporting
-    ;; documentation".  Some files (mainly related to CMake) use
-    ;; alternatively GPL2+ and BSD-3 licenses.
-    (license (list (license:non-copyleft "file:///COPYING")
-                   license:gpl2+
-                   license:bsd-3))))