summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAmin Bandali <mab@gnu.org>2020-01-28 12:06:46 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-28 20:19:25 +0100
commite7c938b2bf591819a64ea0ecb51a863d71339da2 (patch)
tree47308b866df7526dc880c167da178bbc59549563 /gnu/packages
parent4968ea2c9279389d3b2f427dec29d07f1031784c (diff)
downloadguix-e7c938b2bf591819a64ea0ecb51a863d71339da2.tar.gz
gnu: Add emacs-unkillable-scratch.
* gnu/packages/emacs-xyz.scm (emacs-unkillable-scratch): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e5af72121a..e834dfffb3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21212,3 +21212,28 @@ comment.")
     (description "@code{delight} enables customizing or hiding the
 mode-line text (lighter) of major and minor modes.")
     (license license:gpl3+)))
+
+(define-public emacs-unkillable-scratch
+  ;; Use the latest (unreleased) commit as of now, since it contains a handy
+  ;; `unkillable-scratch-do-not-reset-scratch-buffer' customization to not
+  ;; repopulate the scratch buffer with `initial-scratch-message'.
+  (let ((commit "b24c2a760529833f230c14cb02ff6e7ec92288ab")
+        (revision "0"))
+    (package
+      (name "emacs-unkillable-scratch")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/EricCrosson/unkillable-scratch.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "13wjbcxr3km4s96yhpavgs5acs5pvqv3ih1p84diqb3x3i6wd4pa"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/EricCrosson/unkillable-scratch")
+      (synopsis "Prevents the *scratch* buffer from being killed")
+      (description "@code{unkillable-scratch} helps prevent killing buffers
+matching a given regexp.")
+      (license license:gpl2+))))