summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:18:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:35 +0200
commite9218611a60fd8c14e62486b24493b9a6bb01ce0 (patch)
tree9890483b6b348aa18461057f547ae7ac3494e6aa /gnu/packages
parentbea5e1ab56b232dccabde89fc60a6633c1cadf3b (diff)
downloadguix-e9218611a60fd8c14e62486b24493b9a6bb01ce0.tar.gz
gnu: Add texlive-pst-fun.
* gnu/packages/tex.scm (texlive-pst-fun): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 61b6204807..c3fe9eef23 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33020,6 +33020,27 @@ trees (which need not be balanced) with a variety of different
 parameters (including varying numbers of iterations).")
     (license license:lppl)))
 
+(define-public texlive-pst-fun
+  (package
+    (name "texlive-pst-fun")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-fun/" "dvips/pst-fun/"
+                   "source/generic/pst-fun/"
+                   "tex/generic/pst-fun/" "tex/latex/pst-fun/")
+             (base32
+              "070nv0yv0rcfvx36xmya953pk89whrr26irvy0ccb41k66fvw5j1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-fun")
+    (synopsis "Draw funny objects with PSTricks")
+    (description
+     "This is a PSTricks related package for drawing funny objects, like ant, bird,
+fish, kangaroo, etc.  Such objects may be useful for testing other PSTricks
+macros and/or packages. (Or they can be used for fun...)")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")