summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:15:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:25 +0200
commite932ac82b5724e92edd1d9f98ff4db8cf7b739f6 (patch)
tree0da4a47026b8a13d39a90f9f7ff2d26ee4c59271 /gnu/packages
parentf8c8b306ec231c219f85e37601b005d3f98d93c8 (diff)
downloadguix-e932ac82b5724e92edd1d9f98ff4db8cf7b739f6.tar.gz
gnu: Add texlive-ut-thesis.
* gnu/packages/tex.scm (texlive-ut-thesis): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f7742630ca..152bc8c7e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -31521,6 +31521,26 @@ a beautifully formatted, consistent U.S. Patent Application using LaTeX and/or
 LyX.")
     (license license:lppl1.3+)))
 
+(define-public texlive-ut-thesis
+  (package
+    (name "texlive-ut-thesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ut-thesis/"
+                   "source/latex/ut-thesis/"
+                   "tex/latex/ut-thesis/")
+             (base32
+              "0z1rvgy4d2zdagb7x5ymdid02fwnpv2x4dd4jxxkhg9mgq0lscyn")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ut-thesis")
+    (synopsis "University of Toronto thesis style")
+    (description
+     "This LaTeX document class implements the formatting requirements of the
+University of Toronto School of Graduate Studies (SGS), as of Fall 2020.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-vak
   (package
     (name "texlive-vak")