summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-12-23 16:33:25 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-12 17:33:28 +0100
commitea785c2bb83ba6c2fb650e008f0bb8b7bbc25f4a (patch)
treec5e22dd4702c3aec2947c7a0ec3c0756b5bd19ea /gnu/packages
parentcd7763350ac3d4af3c37382f659c17d35ee43690 (diff)
downloadguix-ea785c2bb83ba6c2fb650e008f0bb8b7bbc25f4a.tar.gz
gnu: python-wand: Fix libmagick access.
* gnu/packages/python-xyz.scm (python-wand):
[build-system]: Use pyproject-build-system.
[arguments](phases): Delete phase check. Replace phase find-magickwand
by phase harcode-lib-path.

Change-Id: I3ddf7045a404f76743c14a5b8183ce9f3196ffd1
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46a5e81cb4..37d7dd0dd5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2594,18 +2594,18 @@ conventions and aliases in the same expression.")
        (uri (pypi-uri "Wand" version))
        (sha256
         (base32 "1jpwm956vm35hmgjndr2jwrcql0bwvpsl88q5nr0x8ppxa2380gm"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'find-magickwand
-           (lambda* (#:key inputs #:allow-other-keys)
-             (setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
-             (setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'hardcode-lib-path
+            (lambda _
+              (substitute* "wand/api.py"
+                (("os\\.environ\\.get\\('MAGICK_HOME'\\)")
+                 (string-append "\"" #$(this-package-input "imagemagick") "\""))
+                (("os\\.environ\\.get\\('WAND_MAGICK_LIBRARY_SUFFIX'\\)")
+                 "\".Q16\"")))))))
     (native-inputs
      (list python-pytest))
     (inputs