summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-13 01:48:50 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 02:59:00 +0200
commiteaa147c4882d5f3142053d93dc202ab488fbb336 (patch)
tree5727702571806bf38e443c526320b393498bc2bd /gnu/packages
parentacc8a0c10b71c2ece4c0a005f40b551826ef2876 (diff)
downloadguix-eaa147c4882d5f3142053d93dc202ab488fbb336.tar.gz
gnu: libwpe: Update package definition.
* gnu/packages/webkit.scm (libwpe): Update package definition.
[native-inputs]: Add python-wrapper.
[synopsis]: Modify.
[description]: Modify.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/webkit.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index d18e711892..d3fee105ef 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -67,29 +67,28 @@
   (package
     (name "libwpe")
     (version "1.6.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://wpewebkit.org/releases/libwpe-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "141w35b488jjhanl3nrm0awrbcy6hb579fk8n9vbpx07m2wcd1rm"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://wpewebkit.org/releases/libwpe-"
+                       version ".tar.xz"))
+       (sha256
+        (base32 "141w35b488jjhanl3nrm0awrbcy6hb579fk8n9vbpx07m2wcd1rm"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f))                    ;no tests
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)))
     (inputs
      `(("mesa" ,mesa)))
     (propagated-inputs
-     `(;; In Requires of wpe-1.0.pc.
-       ("libxkbcommon" ,libxkbcommon)))
+     `(("libxkbcommon" ,libxkbcommon)))
+    (synopsis "General-purpose library for WPE")
+    (description "LibWPE is general-purpose library specifically developed for
+the WPE-flavored port of WebKit.")
     (home-page "https://wpewebkit.org/")
-    (synopsis "Platform agnostic WebKit interfaces")
-    (description
-     "@code{libwpe} is a small library that defines programming interfaces
-for use by WebKit, and provides a mechanism for loading a platform-specific
-backend which implements them.")
     (license license:bsd-2)))
 
 (define-public wpebackend-fdo