summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:23 +0200
commiteb11cd738551798c44040b534d20e4332ac3ede2 (patch)
tree1c0c058a79be4211b8e3c1b3f6de91c91a3d556a /gnu/packages
parent06f54631a154cd9c3f23726a6b3f1166f9234058 (diff)
downloadguix-eb11cd738551798c44040b534d20e4332ac3ede2.tar.gz
gnu: Add texlive-srcltx.
* gnu/packages/tex.scm (texlive-srcltx): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e816679914..30435177b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96354,6 +96354,26 @@ spverbatim allow LaTeX to break lines at space characters.")
 to Serbian style.")
     (license license:gpl3+)))
 
+(define-public texlive-srcltx
+  (package
+    (name "texlive-srcltx")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/srcltx/" "source/latex/srcltx/"
+                   "tex/latex/srcltx/")
+             (base32
+              "1yj6clsb89n0aiz8pn7il1vf2pfg369psys3b73dncf92dhlawff")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/srcltx")
+    (synopsis "Jump between DVI and TeX files")
+    (description
+     "This package provides a @code{\\special} insertion into generated @file{.dvi}
+files allowing one to jump from the @file{.dvi} file to the @file{.tex} source
+and back again (given a @file{.dvi} viewer that supports this).")
+    (license license:public-domain)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar