summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:33:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:45 +0200
commiteb1374be7bd50d2d30a184b83f686d6031f82fa4 (patch)
treea162ea2e492f40c84bf6dc5ad81356ed048bdb0d /gnu/packages
parent7d7312186ae9d5a98e362ae21e4c1c8c51c9c51e (diff)
downloadguix-eb1374be7bd50d2d30a184b83f686d6031f82fa4.tar.gz
gnu: Add texlive-pst-soroban.
* gnu/packages/tex.scm (texlive-pst-soroban): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8d5dbc3b87..b6e6bf451b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34061,6 +34061,26 @@ large palette of colors;
 @end itemize")
     (license license:lppl1.3+)))
 
+(define-public texlive-pst-soroban
+  (package
+    (name "texlive-pst-soroban")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-soroban/"
+                   "source/generic/pst-soroban/"
+                   "tex/latex/pst-soroban/")
+             (base32
+              "1cpmqgaj1h2dh3acypm9xkjinmlw9wd40n1s2vdab5ascvprbr6n")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-soroban")
+    (synopsis "Draw a soroban using PSTricks")
+    (description
+     "The package uses PSTricks to draw a Japanese abacus, or soroban.  The
+soroban is still used in Japan today.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")