summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-22 04:09:46 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-04 21:07:06 -0400
commiteb6f3941d7a15720a078979cbdf093470c9fd7a1 (patch)
tree4bf23d08eb169280d8ec8e015704e2684d0ddaad /gnu/packages
parentceb025b42bc0c33f77f179c7c67f844ff05367fc (diff)
downloadguix-eb6f3941d7a15720a078979cbdf093470c9fd7a1.tar.gz
gnu: Add perl-cairo-gobject.
* gnu/packages/gtk.scm (perl-cairo-gobject): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 99a4128286..bc30905444 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -80,6 +80,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages python)
@@ -1595,6 +1596,30 @@ cairo.  It supports multiple output targets, including PNG, PDF and SVG.  Cairo
 produces identical output on all those targets.")
     (license license:lgpl2.1+)))
 
+(define-public perl-cairo-gobject
+  (package
+    (name "perl-cairo-gobject")
+    (version "1.005")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/"
+                           "Cairo-GObject-" version ".tar.gz"))
+       (sha256
+        (base32 "0l2wcz77ndmbgvxx34gdm919a3dxh9fixqr47p50n78ysx2692cd"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-extutils-depends" ,perl-extutils-depends)
+       ("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
+    (propagated-inputs
+     `(("perl-cairo" ,perl-cairo)
+       ("perl-glib" ,perl-glib)))
+    (home-page "https://metacpan.org/dist/Cairo-GObject")
+    (synopsis "Integrate Cairo into the Glib type system")
+    (description "Cairo::GObject registers Cairo's types with Glib's type systems,
+so that they can be used normally in signals and properties.")
+    (license license:lgpl2.1+)))
+
 (define-public perl-gtk2
   (package
     (name "perl-gtk2")