summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commitee769c46381c95f3700c472f78518d283b039690 (patch)
treeba7f689ad416f3250bca10534c71e45e0a52d370 /gnu/packages
parent76aa16ab61e10bd82fa2e4b42e0fb6a672dc6887 (diff)
downloadguix-ee769c46381c95f3700c472f78518d283b039690.tar.gz
gnu: unionfs-fuse-static: Run tests.
* gnu/packages/linux.scm (unionfs-fuse/static)[arguments]: Use
SUBSTITUTE-KEYWORD-ARGUMENTS, inheriting and extending
unionfs-fuse's #:configure-flags and #:phases, and inheriting
its #:tests? #t.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 47229492d8..c2ab05ac5d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3901,21 +3901,19 @@ UnionFS-FUSE additionally supports copy-on-write.")
                (string-append "target_link_libraries"
                               libs " dl)")))))))
     (arguments
-     (list
-      #:tests? #f
-      #:configure-flags
-      #~(list "-DCMAKE_EXE_LINKER_FLAGS=-static")
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'install 'post-install
-            (lambda _
-              ;; By default, 'unionfs' keeps references to
-              ;; $glibc/share/locale and similar stuff.  Remove them.
-              (remove-store-references (string-append #$output "/bin/unionfs"))
-
-              ;; 'unionfsctl' has references to glibc as well.  Since
-              ;; we don't need it, remove it.
-              (delete-file (string-append #$output "/bin/unionfsctl")))))))
+     (substitute-keyword-arguments (package-arguments unionfs-fuse)
+       ((#:configure-flags flags #~'())
+        #~(cons "-DCMAKE_EXE_LINKER_FLAGS=-static" #$flags))
+       ((#:phases phases #~%standard-phases)
+        #~(modify-phases #$phases
+            (add-after 'install 'post-install
+              (lambda _
+                ;; By default, 'unionfs' keeps references to
+                ;; $glibc/share/locale and similar stuff.  Remove them.
+                (remove-store-references (string-append #$output "/bin/unionfs"))
+                ;; 'unionfsctl' has references to glibc as well.  Since
+                ;; we don't need it, remove it.
+                (delete-file (string-append #$output "/bin/unionfsctl"))))))))
     (inputs (list fuse-static))))
 
 (define-public sshfs