summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 13:43:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:56 +0200
commiteec85d8193fe972b69e0d336e855e83ec72c6d39 (patch)
tree1b366d00060e92ce627eda3ae10dd92d51cda686 /gnu/packages
parent179900942d3ad6f26947c570421a71b8666124db (diff)
downloadguix-eec85d8193fe972b69e0d336e855e83ec72c6d39.tar.gz
gnu: rust-c2-chacha-0.2: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-c2-chacha-0.2): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: I3abe34f84ffd1de1410af1b9eabf6d3d42c8e4d6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-crypto.scm30
-rw-r--r--gnu/packages/crates-io.scm29
2 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 67de332f12..3b6c5be991 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1,4 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -144,3 +145,32 @@
               (modules '((guix build utils)))
               (snippet
                '(begin (delete-file-recursively "botan")))))))
+
+(define-public rust-c2-chacha-0.2
+  (package
+    (name "rust-c2-chacha")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "c2-chacha" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "00a11qdc8mg3z0k613rhprkc9p6xz0y7b1681x32ixg0hr3x0r3x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-byteorder" ,rust-byteorder-1)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-ppv-lite86" ,rust-ppv-lite86-0.2)
+        ("rust-stream-cipher" ,rust-stream-cipher-0.3))
+       #:cargo-development-inputs
+       (("rust-hex-literal" ,rust-hex-literal-0.2))))
+    (home-page "https://github.com/cryptocorrosion/cryptocorrosion")
+    (synopsis "The ChaCha family of stream ciphers")
+    (description
+     "The ChaCha family of stream ciphers.")
+    (license (list license:asl2.0 license:expat))))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 712341a101..2eebe90bd6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9593,35 +9593,6 @@ NULL-terminated C linked lists.")
     (description "This package procides structures to wrap C arrays in Rust.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-c2-chacha-0.2
-  (package
-    (name "rust-c2-chacha")
-    (version "0.2.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "c2-chacha" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "00a11qdc8mg3z0k613rhprkc9p6xz0y7b1681x32ixg0hr3x0r3x"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-byteorder" ,rust-byteorder-1)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-ppv-lite86" ,rust-ppv-lite86-0.2)
-        ("rust-stream-cipher" ,rust-stream-cipher-0.3))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.2))))
-    (home-page "https://github.com/cryptocorrosion/cryptocorrosion")
-    (synopsis "The ChaCha family of stream ciphers")
-    (description
-     "The ChaCha family of stream ciphers.")
-    (license (list license:asl2.0 license:expat))))
-
 (define-public rust-cache-padded-1
   (package
     (name "rust-cache-padded")