summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:11:12 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:26 +0100
commitf09654259f88b3a727ac78593435801d5fad72db (patch)
treee9fa06d2b2f8e7389821907b9fd5b74f2e0f0256 /gnu/packages
parent2494d95ededf2ab41a2c3e53ab5c0500a834f3b7 (diff)
downloadguix-f09654259f88b3a727ac78593435801d5fad72db.tar.gz
gnu: go-github-com-chmduquesne-rollinghash: Move to golang-crypto.
* gnu/packages/syncthing.scm (go-github-com-chmduquesne-rollinghash):
Move from here ...
* gnu/packages/golang-crypto.scm: ... to here.

Change-Id: I61a942c07655f51a61e198613eeaa3eb240b8df9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-crypto.scm27
-rw-r--r--gnu/packages/syncthing.scm25
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 499819bac6..d5daa014af 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1,8 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017-2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
-;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -321,6 +321,31 @@ the Ristretto prime-order group built from Edwards25519.")
 xxHash algorithm (XXH64).")
     (license license:expat)))
 
+(define-public go-github-com-chmduquesne-rollinghash
+  (let ((commit "a60f8e7142b536ea61bb5d84014171189eeaaa81")
+        (revision "0"))
+    (package
+      (name "go-github-com-chmduquesne-rollinghash")
+      (version (git-version "4.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/chmduquesne/rollinghash")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0fpaqq4zb0wikgbhn7vwqqj1h865f5xy195vkhivsp922p7qwsjr"))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/chmduquesne/rollinghash/"))
+      (home-page "https://github.com/chmduquesne/rollinghash")
+      (synopsis "Rolling hashes in Go")
+      (description
+       "This package provides a Go implementation of several rolling hashes.")
+      (license license:expat))))
+
 (define-public go-github-com-cloudflare-circl
   (package
     (name "go-github-com-cloudflare-circl")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 50242470c4..fba79da7e2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -308,31 +308,6 @@ inherent errors.")
       (home-page "https://github.com/vitrun/qart")
       (license bsd-3))))
 
-(define-public go-github-com-chmduquesne-rollinghash
-  (let ((commit "a60f8e7142b536ea61bb5d84014171189eeaaa81")
-        (revision "0"))
-    (package
-      (name "go-github-com-chmduquesne-rollinghash")
-      (version (git-version "4.0.0" revision commit))
-      (source
-        (origin
-          (method git-fetch)
-          (uri (git-reference
-                 (url "https://github.com/chmduquesne/rollinghash")
-                 (commit commit)))
-          (file-name (git-file-name name version))
-          (sha256
-           (base32
-            "0fpaqq4zb0wikgbhn7vwqqj1h865f5xy195vkhivsp922p7qwsjr"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/chmduquesne/rollinghash/"))
-      (synopsis "Rolling hashes in Go")
-      (description "This package provides a Go implementation of several rolling
-hashes.")
-      (home-page "https://github.com/chmduquesne/rollinghash")
-      (license expat))))
-
 (define-public go-github-com-syncthing-notify
   (let ((commit "69c7a957d3e261f9744f46b3dd4d608d8480ad90")
         (revision "5"))