summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-11-20 12:39:31 -0600
committerChristopher Baines <mail@cbaines.net>2022-11-21 14:25:14 +0000
commitf0cc7542f535cd0ccb75352cabc465a8dc1b1551 (patch)
treed33d8f852f158673f38ef095c235ec3c670231ec /gnu/packages
parentbb2d7259eed3f00213c3ad66a0de0c94a10f05b2 (diff)
downloadguix-f0cc7542f535cd0ccb75352cabc465a8dc1b1551.tar.gz
gnu: Add emacs-on.
* gnu/packages/emacs-xyz.scm (emacs-on): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 91a37fb911..30606c0994 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22617,6 +22617,29 @@ It replaces the standard completions buffer with Ido prompt.")
 using user-provided rules.")
     (license license:gpl3+)))
 
+(define-public emacs-on
+  (let ((commit "83baed07a105c135190d49d7ec77f95e8f38fa54")
+        (revision "0"))
+    (package
+      (name "emacs-on")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ajgrf/on.el")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "14ly3w89hf4jgd8wacirxgd8vrgj7vc0hpfn911w5wa4k2a6nzpp"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/ajgrf/on.el")
+      (synopsis "Hooks for faster Emacs startup")
+      (description
+       "This package exposes a number of utility hooks and functions ported
+from Doom Emacs.")
+      (license license:expat))))
+
 (define-public emacs-on-screen
   (package
     (name "emacs-on-screen")