summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-21 00:09:56 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-21 01:09:06 +0200
commitf15164e79127a7148fadc98adf6776d37f257044 (patch)
tree19db674151673624d96ba6587a89c05f44aae9e2 /gnu/packages
parent2cd09108c9b316c9c8aa1c1b87b85a1c32cef089 (diff)
downloadguix-f15164e79127a7148fadc98adf6776d37f257044.tar.gz
gnu: Add GNU dmd.
* gnu/packages/system.scm (dmd): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/system.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 7c733f9575..9af0365812 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -25,7 +25,39 @@
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages ncurses)
-  #:use-module (gnu packages linux))
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages guile)
+  #:use-module (gnu packages pkg-config))
+
+(define-public dmd
+  (package
+    (name "dmd")
+    (version "-0.4")
+    (source (origin
+             (method url-fetch)
+
+             ;; XXX: Temporary location until dmd gets back home.
+             (uri (string-append
+                   "http://www.fdn.fr/~lcourtes/software/guix/dmd-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "094ja3xvk9ljghhxmy39if67cfjd1hy6m4svnp399n0wpxvaryvy"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--localstatedir=/var")))
+    (inputs `(("pkg-config" ,pkg-config)
+              ("guile" ,guile-2.0)))
+    (synopsis "Daemon managing daemons")
+    (description "'DMD' is a \"Daemon managing Daemons\" (or
+\"Daemons-managing Daemon\"?)---i.e. a service manager that provides a
+replacement for the service-managing capabilities of SysV-init (or any other
+init) with a both powerful and beautiful dependency-based system with a
+convenient interface.  It is intended for use on GNU/Hurd, but it is supposed
+to work on every POSIX-like system where Guile is available.  In particular,
+it has been tested on GNU/Linux.")
+    (license gpl3+)
+    (home-page "http://www.gnu.org/software/dmd/")))
 
 (define-public dfc
   (package