summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:45:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:30 +0200
commitf45420d38759007bbbcc1be1fcca103c67612fb7 (patch)
treec4ce671fe8fc8ccbcb08c8d910f230335e86d46f /gnu/packages
parent7990b2a21cd27c8aa1cab659ee205a3d82cc4897 (diff)
downloadguix-f45420d38759007bbbcc1be1fcca103c67612fb7.tar.gz
gnu: Add texlive-niceframe-type1.
* gnu/packages/tex.scm (texlive-niceframe-type1): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5356950358..b82a146b80 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19592,6 +19592,27 @@ access to the typewriter fonts from @code{newtx}.  Regular and bold weights,
 slanted variants and a choice of four different styles for zero.")
     (license (list license:gpl3 license:lppl))))
 
+(define-public texlive-niceframe-type1
+  (package
+    (name "texlive-niceframe-type1")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/niceframe-type1/"
+                   "fonts/afm/public/niceframe-type1/"
+                   "fonts/map/dvips/niceframe-type1/"
+                   "fonts/type1/public/niceframe-type1/")
+             (base32
+              "0np6m165d5xa4y68hy62q39wp069darx63snzl168flj0j1q6qbl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/niceframe-type1")
+    (synopsis "Type 1 versions of the fonts recommended in @code{niceframe}")
+    (description
+     "The bundle provides Adobe Type 1 versions of the fonts @code{bbding10},
+@code{dingbat}, @code{karta15}, @code{umranda} and @code{umrandb}.")
+    (license license:lppl)))
+
 (define-public texlive-nicematrix
   (package
     (name "texlive-nicematrix")