summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-28 08:40:00 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:05 +0100
commitf487618b13fcc336ad25fe9a299867ee12b11a3b (patch)
treec6116e9150806da063e3cbbc5ba3c6e000357727 /gnu/packages
parentd92e4f59bbb276e40c1dfffa35f5e6ed8dae8bab (diff)
downloadguix-f487618b13fcc336ad25fe9a299867ee12b11a3b.tar.gz
gnu: phonon: Use gexp.
* gnu/packages/kde-frameworks.scm (phonon): Use gexp.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d1356931a1..f9e43583de 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -231,18 +231,18 @@ continuous display of high-volume data.")
     (inputs
      (list qtbase-5))
     (arguments
-     `(#:configure-flags
-       '("-DCMAKE_CXX_FLAGS=-fPIC"
-         "-DPHONON_BUILD_PHONON4QT5=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'patch-installdir
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((regex (string-append "(INSTALL DESTINATION \")"
-                                         (assoc-ref inputs "qtbase"))))
-               (substitute* "cmake_install.cmake"
-                 ((regex all dest)
-                  (string-append dest (assoc-ref outputs "out"))))))))))
+     (list #:configure-flags
+           #~'("-DCMAKE_CXX_FLAGS=-fPIC"
+               "-DPHONON_BUILD_PHONON4QT5=ON")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'install 'patch-installdir
+                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                   (let ((regex (string-append "(INSTALL DESTINATION \")"
+                                               #$(this-package-input "qtbase"))))
+                     (substitute* "cmake_install.cmake"
+                       ((regex all dest)
+                        (string-append dest #$output)))))))))
     (home-page "https://community.kde.org/Phonon")
     (synopsis "KDE's multimedia library")
     (description "KDE's multimedia library.")