summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-16 17:38:39 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 23:25:19 +0200
commitf4f6d6582bd393355939ea9dffa8f76f1fd00d4c (patch)
tree5d9e21996f87310a2939dd4774d648c2e5f409af /gnu/packages
parent6140e8c45db79fc77d97eef31af5631bb54bf7b5 (diff)
downloadguix-f4f6d6582bd393355939ea9dffa8f76f1fd00d4c.tar.gz
gnu: pangomm: Remove input labels.
* gnu/packages/gtk.scm (pangomm)[native-inputs]: Remove labels.
[arguments]: While at it, remove trailing #t.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 918f2204fe..81d34a5151 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1610,10 +1610,8 @@ library.")
     (build-system meson-build-system)
     (outputs '("out" "doc"))
     (arguments
-     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
-       #:configure-flags
-       (list
-        "-Dbuild-documentation=true")
+     '(#:glib-or-gtk? #t
+       #:configure-flags '("-Dbuild-documentation=true")
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'move-doc
@@ -1623,17 +1621,16 @@ library.")
                (mkdir-p (string-append doc "/share"))
                (rename-file
                 (string-append out "/share/doc")
-                (string-append doc "/share/doc"))
-               #t))))))
+                (string-append doc "/share/doc"))))))))
     (native-inputs
-     `(("dot" ,graphviz)
-       ("doxygen" ,doxygen)
-       ("m4" ,m4)
-       ("mm-common" ,mm-common)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python)
-       ("xsltproc" ,libxslt)))
+     (list doxygen
+           graphviz                     ;for 'dot'
+           libxslt                      ;for 'xsltproc'
+           m4
+           mm-common
+           perl
+           pkg-config
+           python))
     (propagated-inputs
      (list cairo cairomm glibmm pango))
     (home-page "https://pango.gnome.org//")