summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-13 16:38:58 +0200
committerMarius Bakke <marius@gnu.org>2021-05-13 17:03:49 +0200
commitf5ca7e71e6a9bc9df4d585ef0084411f665902ec (patch)
tree61c11c4da192f551bd74f79388ceaffbf09f5135 /gnu/packages
parent2feea84c49103c21c3da0835204347550d95048b (diff)
downloadguix-f5ca7e71e6a9bc9df4d585ef0084411f665902ec.tar.gz
gnu: elogind: Fix build failure with GCC 10.
* gnu/packages/freedesktop.scm (elogind)[arguments]: Adjust substitution so
that the disabled test does not return from a void, which is not allowed in
newer GCC.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6c05c9a984..081cae50e7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -645,7 +645,7 @@ the freedesktop.org XDG Base Directory specification.")
              ;; logind system so that it can flicker the monitor, etc.
              ;; Just skip it until a more narrow selection can be made.
              (substitute* "src/libelogind/sd-login/test-login.c"
-               (("r = sd_pid_get_slice.*")
+               (("test_login\\(\\);")
                 "return 77;"))
              #t))
          (add-after 'unpack 'change-pid-file-path