summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:11:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:33 +0200
commitf5cb25f11379256534b6ce24bc733b5ff64f2452 (patch)
tree71ce33b9cb26db4227b6d4d5a7b4df0a4b6baf5f /gnu/packages
parentbb0a714271f72b91f9f3745b0cbf8c73a1a998c0 (diff)
downloadguix-f5cb25f11379256534b6ce24bc733b5ff64f2452.tar.gz
gnu: Add texlive-ketcindy.
* gnu/packages/tex.scm (texlive-ketcindy): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c1c30cef44..2fd021410f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2455,6 +2455,29 @@ does pdfTeX.")
 PostScript.")
     (license license:lppl)))
 
+(define-public texlive-ketcindy
+  (package
+    (name "texlive-ketcindy")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/support/ketcindy/" "scripts/ketcindy/"
+                   "tex/latex/ketcindy/")
+             (base32
+              "0jy8fzfqwbmnza43j70c22wr0nvx9km8g4n5vcgnjvc6js2nyxas")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "ketcindy.pl")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/ketcindy")
+    (synopsis "Macros for graphic generation and Cinderella plugin")
+    (description
+     "KETpic is a macro package designed for computer algebra systems (CAS) to
+generate LaTeX source codes for high-quality mathematical artwork.  KETcindy
+is a plugin for Cinderella that allows to generate graphics using KETpic.  The
+generated code can be included in any LaTeX document.")
+    (license license:gpl3+)))
+
 (define-public texlive-tex-ini-files
   (package
     (name "texlive-tex-ini-files")