summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-27 21:09:02 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-27 21:09:02 +0200
commitf887601ac8b0d51f38e5f82057f6d133611bbe94 (patch)
treefeea978e450bab2bd86bb64f9adf233353d61518 /gnu/packages
parent867e3c5553515e74ea2263a430bae4c337f4b84c (diff)
downloadguix-f887601ac8b0d51f38e5f82057f6d133611bbe94.tar.gz
gnu: guix: Update to 0.4.
* gnu/packages/package-management.scm (guix): Update to 0.4.
  (guix-0.4): Remove.
* gnu/system/vm.scm (qemu-image, system-qemu-image): Use GUIX instead of
  GUIX-0.4.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/package-management.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 000d1787f0..948af65bbd 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -30,14 +30,14 @@
 (define-public guix
   (package
     (name "guix")
-    (version "0.3")
+    (version "0.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://alpha.gnu.org/gnu/guix/guix-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0xpfdmlfkkpmgrb8lpaqs5wxx31m4jslajs6b9waz5wp91zk7fix"))))
+               "1mmh28ds5p8mpzm2yfvgm6z92wgknqc3dlw6r6z16s13sk386igk"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list
@@ -104,16 +104,3 @@ A user-land free software distribution for GNU/Linux comes as part of Guix.
 Guix is based on the Nix package manager.")
     (license gpl3+)))
 
-(define-public guix-0.4
-  ;; XXX: Hack to allow the use of a 0.4ish tarball.  This assumes that you
-  ;; have run 'make dist' in your build tree.  Remove when 0.4 is out.
-  (let* ((builddir (dirname
-                    (canonicalize-path
-                     (dirname (search-path %load-path
-                                           "guix/config.scm")))))
-         (tarball  (string-append builddir "/guix-0.4.tar.gz")))
-    (package (inherit guix)
-      (version "0.4rc")
-      (source (if (file-exists? tarball)
-                  tarball
-                  (package-source guix))))))