summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-16 21:58:12 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-08-27 18:02:35 -0400
commitf8da3af08655acf2bb016e3a84bcba9b16e667ff (patch)
tree6cd03d1147b9e1eacd089c27e4fb4016b5328ba1 /gnu/packages
parent555e436ea2f8ffebd02983318fcc091277dc6f7d (diff)
downloadguix-f8da3af08655acf2bb016e3a84bcba9b16e667ff.tar.gz
gnu: Add ruby-arel.
* gnu/packages/ruby.scm (ruby-arel): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 65de4d1d07..9a702dd454 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -610,3 +610,21 @@ options and parsing command line flags.")
 net/http library.")
     (home-page "https://github.com/nicksieger/multipart-post")
     (license license:expat)))
+
+(define-public ruby-arel
+  (package
+    (name "ruby-arel")
+    (version "6.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "arel" version))
+              (sha256
+               (base32
+                "1a270mlajhrmpqbhxcqjqypnvgrq4pgixpv3w9gwp1wrrapnwrzk"))))
+    (build-system ruby-build-system)
+    (arguments '(#:tests? #f)) ; no tests
+    (home-page "https://github.com/rails/arel")
+    (synopsis "SQL AST manager for Ruby")
+    (description "Arel is a SQL AST manager for Ruby.  It simplifies the
+generation of complex SQL queries and is compatible with various RDBMSes.")
+    (license license:expat)))