summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-07-26 19:56:46 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:50 -0500
commitfa7b52ff577dc9b44c2dec6b4a1147640d1e4e28 (patch)
tree020f144d347e818b7e98ddfb1c2bdacd406535a9 /gnu/packages
parenta97d659e139a908a1e3d806c8e51b3158c9af456 (diff)
downloadguix-fa7b52ff577dc9b44c2dec6b4a1147640d1e4e28.tar.gz
gnu: python-pdfminer-six: Remove obsolete phase.
* gnu/packages/python-xyz.scm (python-pdfminer-six)[arguments]
<#:phases>: Remove 'make-files-writable phase.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ffcee6732..4be21e2023 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14746,13 +14746,7 @@ module, adding support for Unicode strings.")
              #t))
          (replace 'check
            (lambda _
-             (invoke "make" "test")))
-         (add-before 'reset-gzip-timestamps 'make-files-writable
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (for-each make-file-writable
-                         (find-files out "\\.gz$"))
-               #t))))))
+             (invoke "make" "test"))))))
     (propagated-inputs
      (list python-chardet python-cryptography python-sortedcontainers))
     (native-inputs