summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-11 15:51:13 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-11 15:51:13 +0200
commitfc50e9c69425c74b4367feb46b83cc28aeb178c2 (patch)
tree97ab2c78b786ed6ee2a3270a9575a0aaf1c6bbae /gnu/packages
parent824af8cadc1b4f1ac7a859f3d18cbe69b195a844 (diff)
downloadguix-fc50e9c69425c74b4367feb46b83cc28aeb178c2.tar.gz
gnu: Add python-dateutil, python2-dateutil.
* gnu/packages/python.scm (python-dateutil, python2-dateutil): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 55d23e45e8..b50a893e1d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -218,6 +218,7 @@ using Python 2.4 or higher and provides access to the Olson timezone database.")
 (define-public python2-pytz
   (package-with-python2 python-pytz))
 
+
 (define-public python-babel
   (package
     (name "python-babel")
@@ -248,6 +249,7 @@ etc. ")
 (define-public python2-babel
   (package-with-python2 python-babel))
 
+
 (define-public python-setuptools
   (package
     (name "python-setuptools")
@@ -283,3 +285,30 @@ Python 3 support.")
 
 (define-public python2-setuptools
   (package-with-python2 python-setuptools))
+
+
+(define-public python-dateutil
+  (package
+    (name "python-dateutil")
+    (version "1.5") ; last version for python < 3
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://labix.org/download/python-dateutil/python-dateutil-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0fqfglhy5khbvsipr3x7m6bcaqljh8xl5cw33vbfxy7qhmywm2n0"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://labix.org/python-dateutil")
+    (synopsis
+     "Extensions to the standard datetime module, available in Python 2.3+")
+    (description
+     "The dateutil module provides powerful extensions to the standard
+datetime module, available in Python 2.3+.")
+    (license psfl)))
+
+(define-public python2-dateutil
+  (package-with-python2 python-dateutil))