summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:13:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:46 +0200
commitfc6c52c54f6e77f0ef792bb726102190662fbcb6 (patch)
tree92c03009e903a15a995e835e428fb5435ffa120a /gnu/packages
parent31a23063d3093116e9ccce0d37ba091054ca3d30 (diff)
downloadguix-fc6c52c54f6e77f0ef792bb726102190662fbcb6.tar.gz
gnu: Add texlive-lps.
* gnu/packages/tex.scm (texlive-lps): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4fea3495f4..9e07c5f0df 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19966,6 +19966,27 @@ from use of the package are in the format used in the textbook @emph{Language,
 Proof, and Logic} by Dave Barker-Plummer, Jon Barwise, and John Etchemendy.")
     (license license:lppl1.3+)))
 
+(define-public texlive-lps
+  (package
+    (name "texlive-lps")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/lps/" "source/latex/lps/"
+                   "tex/latex/lps/")
+             (base32
+              "11jd8k1w2mk0xmwaxb1ps8pabxlzvs24z5hl74dwcim2xad7ahvj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lps")
+    (synopsis "Class for @emph{Logic and Philosophy of Science}")
+    (description
+     "The @emph{Logic and Philosophy of Science} journal is an online
+publication of the University of Trieste (Italy).  The class builds on the
+standard article class to offer a format that LaTeX authors may use when
+submitting to the journal.")
+    (license license:lppl)))
+
 (define-public texlive-lshort-bulgarian
   (package
     (name "texlive-lshort-bulgarian")