summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOlivier Dion <odion@efficios.com>2023-02-15 15:59:58 -0500
committerLudovic Courtès <ludo@gnu.org>2023-02-27 23:40:44 +0100
commitff5fbcc19bce6e94ead0cc79b27ae8ed0307463d (patch)
treeb9221027b9a1d9f0f08699b2153aa5cd9ab67c16 /gnu/packages
parenta7458a627827a3047aed1560d0afd454296422bc (diff)
downloadguix-ff5fbcc19bce6e94ead0cc79b27ae8ed0307463d.tar.gz
gnu: Add barectf.
* gnu/packages/instrumentation.scm (barectf): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/instrumentation.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 133d684567..c25086127a 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -43,6 +43,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages swig)
@@ -53,6 +54,7 @@
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system linux-module)
+  #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
@@ -120,6 +122,32 @@ LTTng and barectf.  This package provides a library with a C API, Python 3
 bindings, and the command-line tool @command{babeltrace2}.")
     (license license:expat)))
 
+(define-public barectf
+  (package
+    (name "barectf")
+    (version "3.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "barectf" version))
+              (sha256
+               (base32
+                "0zhc9d4qnnl4fjj6354qb4bng4ykywn8x3l3acpv6sx439q6ylwd"))))
+    (build-system python-build-system)
+    (native-inputs (list gcc-toolchain
+                         gnu-make
+                         python-jinja2
+                         python-jsonschema
+                         python-pyyaml-5
+                         python-termcolor
+                         python-tox))
+    (home-page "https://barectf.org")
+    (synopsis "CTF tracer generator")
+    (description
+     "@command{barectf} is a generator of tracer which produces CTF data
+streams.  The generated C source code has no other dependencies than a few C
+standard library headers.")
+    (license license:expat)))
+
 (define-public dyninst
   (package
     (name "dyninst")