summary refs log tree commit diff
path: root/gnu/services
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
commit9dea3f101f252331c049c03f501398a5ec837ba9 (patch)
tree61d683a9fae3e147332d07fef207c1ddf51fc301 /gnu/services
parent7f0af119a1e3ea9d0ae53811b619437b3e942702 (diff)
parent620669fd17306c2edb21c64a99fa47160fefb319 (diff)
downloadguix-9dea3f101f252331c049c03f501398a5ec837ba9.tar.gz
Merge branch 'master' into core-updates
Conflicts:
	gnu/packages/cups.scm
	gnu/packages/python-web.scm
	gnu/packages/web.scm
	guix/build/maven/pom.scm
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/cups.scm24
-rw-r--r--gnu/services/security-token.scm4
-rw-r--r--gnu/services/ssh.scm11
3 files changed, 24 insertions, 15 deletions
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 13657e36a7..3caa954579 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -292,11 +292,12 @@ methods.  Otherwise apply to only the listed methods.")
    "Name of the policy.")
   (job-private-access
    (string "@OWNER @SYSTEM")
-   "Specifies an access list for a job's private values.  @code{@@ACL} maps to
-the printer's requesting-user-name-allowed or requesting-user-name-denied
-values.  @code{@@OWNER} maps to the job's owner.  @code{@@SYSTEM} maps to the
-groups listed for the @code{system-group} field of the @code{files-config}
-configuration, which is reified into the @code{cups-files.conf(5)} file.
+   "Specifies an access list for a job's private values.
+@code{@@ACL} maps to the printer's requesting-user-name-allowed or
+requesting-user-name-denied values.  @code{@@OWNER} maps to the job's owner.
+@code{@@SYSTEM} maps to the groups listed for the @code{system-group} field of
+the @code{files-configuration}, which is reified into the
+@code{cups-files.conf(5)} file.
 Other possible elements of the access list include specific user names, and
 @code{@@@var{group}} to indicate members of a specific group.  The access list
 may also be simply @code{all} or @code{default}.")
@@ -312,11 +313,11 @@ may also be simply @code{all} or @code{default}.")
 @code{@@ACL} maps to the printer's requesting-user-name-allowed or
 requesting-user-name-denied values.  @code{@@OWNER} maps to the job's owner.
 @code{@@SYSTEM} maps to the groups listed for the @code{system-group} field of
-the @code{files-config} configuration, which is reified into the
-@code{cups-files.conf(5)} file.  Other possible elements of the access list
-include specific user names, and @code{@@@var{group}} to indicate members of a
-specific group.  The access list may also be simply @code{all} or
-@code{default}.")
+the @code{files-configuration}, which is reified into the
+@code{cups-files.conf(5)} file.
+Other possible elements of the access list include specific user names, and
+@code{@@@var{group}} to indicate members of a specific group.  The access list
+may also be simply @code{all} or @code{default}.")
   (subscription-private-values
    (string (string-join '("notify-events" "notify-pull-method"
                           "notify-recipient-uri" "notify-subscriber-user-name"
@@ -617,9 +618,6 @@ policy is @code{retry-job} or @code{retry-current-job}.")
   (keep-alive?
    (boolean #t)
    "Specifies whether to support HTTP keep-alive connections.")
-  (keep-alive-timeout
-   (non-negative-integer 30)
-   "Specifies how long an idle client connection remains open, in seconds.")
   (limit-request-body
    (non-negative-integer 0)
    "Specifies the maximum size of print files, IPP requests, and HTML form
diff --git a/gnu/services/security-token.scm b/gnu/services/security-token.scm
index ec26006538..0cbb591e10 100644
--- a/gnu/services/security-token.scm
+++ b/gnu/services/security-token.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,6 +58,9 @@
         (requirement '(syslogd))
         (modules '((gnu build shepherd)))
         (start #~(lambda _
+                   (let ((socket "/run/pcscd/pcscd.comm"))
+                     (when (file-exists? socket)
+                       (delete-file socket)))
                    (invoke #$(file-append pcsc-lite "/sbin/pcscd"))
                    (call-with-input-file "/run/pcscd/pcscd.pid" read)))
         (stop #~(make-kill-destructor)))))))
diff --git a/gnu/services/ssh.scm b/gnu/services/ssh.scm
index 1891db0487..a018052eeb 100644
--- a/gnu/services/ssh.scm
+++ b/gnu/services/ssh.scm
@@ -6,6 +6,8 @@
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 pinoaffe <pinoaffe@airmail.cc>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,6 +32,7 @@
   #:use-module (gnu services web)
   #:use-module (gnu system pam)
   #:use-module (gnu system shadow)
+  #:use-module (guix deprecation)
   #:use-module (guix gexp)
   #:use-module (guix records)
   #:use-module (guix modules)
@@ -288,7 +291,7 @@ The other options should be self-descriptive."
   ;; integer
   (port-number           openssh-configuration-port-number
                          (default 22))
-  ;; Boolean | 'without-password
+  ;; Boolean | 'prohibit-password
   (permit-root-login     openssh-configuration-permit-root-login
                          (default #f))
   ;; Boolean
@@ -441,7 +444,11 @@ of user-name/file-like tuples."
                    #$(match (openssh-configuration-permit-root-login config)
                        (#t "yes")
                        (#f "no")
-                       ('without-password "without-password")))
+                       ('without-password (warn-about-deprecation
+                                           'without-password #f
+                                           #:replacement 'prohibit-password)
+                                          "prohibit-password")
+                       ('prohibit-password "prohibit-password")))
            (format port "PermitEmptyPasswords ~a\n"
                    #$(if (openssh-configuration-allow-empty-passwords? config)
                          "yes" "no"))