summary refs log tree commit diff
path: root/gnu/services
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-23 14:59:17 +0100
committerChristopher Baines <mail@cbaines.net>2020-10-23 15:40:10 +0100
commitb0d6098f03ed297fda2bdb2dfdf36a2ae0f8bd8d (patch)
tree9619fcc27298aa4fe376050704374db24bc5781b /gnu/services
parent4b8acf715dd806f9034e7c7a073e6b49301985d3 (diff)
downloadguix-b0d6098f03ed297fda2bdb2dfdf36a2ae0f8bd8d.tar.gz
gnu: guix-build-coordinator: Propagate the guile inputs.
This means the package is usable as a library, which is useful when using the
procedures to send requests to the Guix Build Coordinator.

* gnu/packages/package-management.scm (guix-build-coordinator)[inputs]: Move
guile inputs to propagated inputs.
[propagated-inputs]: Receive some inputs.
* gnu/services/guix.scm (make-guix-build-coordinator-start-script): Adjust the
start script to include propagated inputs.
Diffstat (limited to 'gnu/services')
-rw-r--r--gnu/services/guix.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/services/guix.scm b/gnu/services/guix.scm
index 87f00338da..b909c651cc 100644
--- a/gnu/services/guix.scm
+++ b/gnu/services/guix.scm
@@ -188,8 +188,11 @@
                           ;; libraries, but it means that the Guile libraries
                           ;; needed for the Guix Build Coordinator don't need
                           ;; to be individually specified here.
-                          (map second (package-inputs
-                                       guix-build-coordinator-package)))
+                          (append
+                           (map second (package-inputs
+                                        guix-build-coordinator-package))
+                           (map second (package-propagated-inputs
+                                        guix-build-coordinator-package))))
      #~(begin
          (use-modules (srfi srfi-1)
                       (ice-9 match)