summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-07-15 10:32:31 +0200
committerTimothy Sample <samplet@ngyro.com>2019-08-07 22:05:32 -0400
commit0173cdd31d73399c75cf29b7de30d44b1e1be54a (patch)
treefe1018b1c08ee2bf61f24adfae12b439e864ecf9 /gnu
parent4ba66e6f163c00a8855a78f9dec061ba225cbdef (diff)
downloadguix-0173cdd31d73399c75cf29b7de30d44b1e1be54a.tar.gz
gnu: Add ghc-http-common.
* gnu/packages/haskell-web.scm (ghc-http-common): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 4bb790d93c..319b1f8d97 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1294,3 +1294,31 @@ derivations of regular expressions.")
      "The Haskell XML Toolbox bases on the ideas of HaXml and HXML, but
 introduces a more general approach for processing XML with Haskell.")
     (license license:expat)))
+
+(define-public ghc-http-common
+  (package
+    (name "ghc-http-common")
+    (version "0.8.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "http-common/http-common-" version ".tar.gz"))
+       (sha256
+        (base32
+         "14s5a178sb2vm5k00rs21760mds5dz2gs10k9iyn22h01mxyf599"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-base64-bytestring" ,ghc-base64-bytestring)
+       ("ghc-blaze-builder" ,ghc-blaze-builder)
+       ("ghc-case-insensitive" ,ghc-case-insensitive)
+       ("ghc-network" ,ghc-network)
+       ("ghc-unordered-containers" ,ghc-unordered-containers)))
+    (home-page "https://github.com/afcowie/http-streams/")
+    (synopsis "Common types for HTTP clients and servers")
+    (description "Base types used by a variety of HTTP clients and
+servers.  See http-streams @code{Network.Http.Client} or pipes-http
+@code{Pipes.Http.Client} for full documentation.  You can import
+@code{Network.Http.Types} if you like, but both http-streams and
+pipes-http re-export this package's types and functions.")
+    (license license:bsd-3)))