summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-23 10:36:37 -0400
committerLeo Famulari <leo@famulari.name>2023-04-23 10:37:24 -0400
commit0244132db6b468311e95a3e32306613e3d5166bc (patch)
treed2b47daa77c7e06429ccf92f2bcca011153b40cc /gnu
parent4502de61f24a5d50a2eb8fdd073162fb939b1e2e (diff)
downloadguix-0244132db6b468311e95a3e32306613e3d5166bc.tar.gz
gnu: khal: Update to 0.11.1.
* gnu/packages/calendar.scm (khal): Update to 0.11.1.
[inputs]: Remove sqlite.
[description]: Add some more information.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/calendar.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index cf4286100d..e93c9838b3 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -181,13 +181,13 @@ data units.")
 (define-public khal
   (package
     (name "khal")
-    (version "0.10.5")
+    (version "0.11.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "khal" version))
               (sha256
                (base32
-                "0xhcrx7lcjk126i2xgqmgb199vd4hxsq34mkdmhdh9ia62nbgvsf"))))
+                "07k0cfbfkx9fhfk4gf73vh34c05i1cb72gc15a1lmx9knxy4h503"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; The test suite is unreliable. See <https://bugs.gnu.org/44197>
@@ -206,8 +206,7 @@ data units.")
            ;; Required to build manpage
            python-sphinxcontrib-newsfeed python-sphinx))
     (inputs
-     (list sqlite
-           python-configobj
+     (list python-configobj
            python-dateutil
            python-icalendar
            python-tzlocal
@@ -220,7 +219,9 @@ data units.")
            python-pyxdg))
     (synopsis "Console calendar program")
     (description "Khal is a standards based console calendar program,
-able to synchronize with CalDAV servers through vdirsyncer.")
+able to synchronize with CalDAV servers through vdirsyncer.  It includes
+both a @acronym{CLI, command-line interface} and a @acronym{TUI, textual user
+interface} named 'ikhal'.")
     (home-page "https://lostpackets.de/khal/")
     (license license:expat)))