summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-12-29 19:40:12 -0500
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:01 +0200
commit029ce0713e80298d399936e01f1f52be3042f991 (patch)
treea27a5615d41cba13403ce8cfee24f2165dd7eb39 /gnu
parent3bc167f42ed0924c51c2dc477cdce41a437ebc29 (diff)
downloadguix-029ce0713e80298d399936e01f1f52be3042f991.tar.gz
gnu: Add rust-fancy-regex-0.11.
* gnu/packages/crates-io.scm (rust-fancy-regex-0.11): New variable.
(rust-fancy-regex-0.7): Inherit from rust-fancy-regex-0.11.

Change-Id: I1dabe4d2aab7869ed1df098b5901bb951fd125d0
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f12c40e145..1aa5f36675 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24443,23 +24443,24 @@ provides implementations for @code{HashMap} and @code{HashSet}.")
     (description "Fallible streaming iteration")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-fancy-regex-0.7
+(define-public rust-fancy-regex-0.11
   (package
     (name "rust-fancy-regex")
-    (version "0.7.1")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "fancy-regex" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1krwc8mbj8zv4ahvh3lqkmfxf38cg79ya02by19fn4jil1h8aswx"))))
+        (base32 "18j0mmzfycibhxhhhfja00dxd1vf8x5c28lbry224574h037qpxr"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-bit-set" ,rust-bit-set-0.5)
-        ("rust-regex" ,rust-regex-1))))
+     `(#:cargo-inputs (("rust-bit-set" ,rust-bit-set-0.5)
+                       ("rust-regex" ,rust-regex-1))
+       #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-matches" ,rust-matches-0.1)
+                                   ("rust-quickcheck" ,rust-quickcheck-1))))
     (home-page "https://github.com/fancy-regex/fancy-regex")
     (synopsis "Implementation of regexes with a rich set of features")
     (description
@@ -24470,6 +24471,24 @@ implement features such as look-around and backtracking, which are not
 supported in purely NFA-based implementations.")
     (license license:expat)))
 
+(define-public rust-fancy-regex-0.7
+  (package
+    (inherit rust-fancy-regex-0.11)
+    (name "rust-fancy-regex")
+    (version "0.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fancy-regex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1krwc8mbj8zv4ahvh3lqkmfxf38cg79ya02by19fn4jil1h8aswx"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-bit-set" ,rust-bit-set-0.5)
+        ("rust-regex" ,rust-regex-1))))))
+
 (define-public rust-fast-chemail-0.9
   (package
     (name "rust-fast-chemail")