summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-17 12:58:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-17 13:01:50 +0300
commit0329f6f76c147f84b7de2faf847a62a6db3d7158 (patch)
treef1c1b65b99f1f4bf2394adaa77e858c790f17a51 /gnu
parentb6598237f224f15f8f24de21acb38178da0e0540 (diff)
downloadguix-0329f6f76c147f84b7de2faf847a62a6db3d7158.tar.gz
gnu: efl: Hardcode libcurl path.
* gnu/packages/enlightenment.scm (efl)[arguments]: Hardcode the location
of libcurl.so.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/enlightenment.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index aa7b87c2ba..ec22d8a5ec 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -149,6 +149,16 @@
                            "--enable-drm")
        #:phases
        (modify-phases %standard-phases
+         ;; If we don't hardcode the location of libcurl.so then we
+         ;; have to wrap the outputs of efl's dependencies in curl.
+         (add-after 'unpack 'hardcode-libcurl-location
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let* ((curl (assoc-ref inputs "curl"))
+                    (lib  (string-append curl "/lib/")))
+               (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
+                 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
+                  (string-append lib libcurl)))
+               #t)))
          (add-after 'unpack 'set-home-directory
            ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
            (lambda _ (setenv "HOME" "/tmp") #t)))))