summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-21 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-21 02:00:12 +0200
commit0337b65284d353b3c4fa05c7f92ac184d4c7d113 (patch)
treee105a7e369d0abfc86a7b1f8a785cac4bda9c775 /gnu
parent504e06012687dd2ff11af60528e4232fbdeca85e (diff)
downloadguix-0337b65284d353b3c4fa05c7f92ac184d4c7d113.tar.gz
gnu: python-lzo: Use G-expressions.
* gnu/packages/python-compression.scm (python-lzo)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-compression.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index b3d7925aa5..0504dd0b2a 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -204,17 +204,18 @@ Python.")
         (base32 "0315nq6r39n51n8qqamb7xv0ib0qrh76q7g3a1977172mbndijw3"))))
     (build-system python-build-system)
     (arguments
-     `(#:test-target "check"
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-setuppy
-           (lambda _
-             (substitute* "setup.py"
-               (("include_dirs.append\\(.*\\)")
-                (string-append "include_dirs.append('"
-                               (assoc-ref %build-inputs "lzo")
-                               "/include/lzo"
-                               "')"))))))))
+     (list
+      #:test-target "check"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-setuppy
+            (lambda _
+              (substitute* "setup.py"
+                (("include_dirs.append\\(.*\\)")
+                 (string-append "include_dirs.append('"
+                                #$(this-package-input "lzo")
+                                "/include/lzo"
+                                "')"))))))))
     (inputs
      (list lzo))
     (home-page "https://github.com/jd-boyd/python-lzo")