summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-12 11:36:14 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:19 -0500
commit03f2055e4063ff891b49b8e3e3a6054df00c6b0a (patch)
treee4f4467f0d556c69f45ed5d6f94de10c8c4fe576 /gnu
parent75924438e602c56d43ea5fba0c347dc459a3dcd0 (diff)
downloadguix-03f2055e4063ff891b49b8e3e3a6054df00c6b0a.tar.gz
gnu: gst-editing-services: Update to 1.18.4.
* gnu/packages/gstreamer.scm (gst-editing-services)[version]: Update to 1.18.4.
[arguments](glib-or-gtk): New argument.
[inputs]: Add glib, glib-networking and gtk+. Move gst-plugins-base to ...
[propagated-inputs]: ... here. Add gstreamer.
[native-inputs]: Replace python with python-wrapper.

Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a375bfe3d8..180604ccbc 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1000,7 +1000,7 @@ decoders, muxers, and demuxers provided by FFmpeg.")
 (define-public gst-editing-services
   (package
     (name "gst-editing-services")
-    (version "1.18.2")
+    (version "1.18.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1008,15 +1008,21 @@ decoders, muxers, and demuxers provided by FFmpeg.")
                     "gst-editing-services-" version ".tar.xz"))
               (sha256
                (base32
-                "0pv2k8zlpn3vv2sdlspi3m63ixcwzi90pjly2ypbkg59ab97rb15"))))
+                "010xg960qsh5dwmf0y9l1q13h0cymmrgapzla2zsw66ylxqbi1s6"))))
     (build-system meson-build-system)
     (arguments
      ;; FIXME: 16/22 failing tests.
      `(#:tests? #f
+       #:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases (modify-phases %standard-phases
                   ,@%common-gstreamer-phases)))
+    (propagated-inputs
+     `(("gstreamer" ,gstreamer)
+       ("gst-plugins-base" ,gst-plugins-base)))
     (inputs
-     `(("gst-plugins-base" ,gst-plugins-base)
+     `(("glib" ,glib)
+       ("glib-networking" ,glib-networking)
+       ("gtk+" ,gtk+)
        ("libxml2" ,libxml2)))
     (native-inputs
      `(("flex" ,flex)
@@ -1026,7 +1032,7 @@ decoders, muxers, and demuxers provided by FFmpeg.")
        ("gst-plugins-good" ,gst-plugins-good)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("python" ,python)))
+       ("python" ,python-wrapper)))
     (home-page "https://gstreamer.freedesktop.org/")
     (synopsis "GStreamer library for non-linear editors")
     (description