summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-02-15 11:09:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-02-15 11:43:25 +0200
commit04ac1a248c188e4e49e6372e8336c31d32d1c96e (patch)
tree0dc2382b89eb5df87d2e27b28fe3eae0bac85f76 /gnu
parent3f929203cf9c387dd9972a05b3c3af608d2bd21d (diff)
downloadguix-04ac1a248c188e4e49e6372e8336c31d32d1c96e.tar.gz
gnu: ghc@4: Replace config.sub using config package.
* gnu/packages/haskell.scm (ghc@4)[arguments]: Adjust custom 'bootstrap
phase to adjust replacement of config.sub.
[native-inputs]: Remove automake, add config.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6a1ca7c7e8..effc6eeb1b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015, 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2018, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
@@ -205,8 +205,8 @@ is itself quite fast.")
            (lambda* (#:key inputs #:allow-other-keys)
              (delete-file "configure")
              (delete-file "config.sub")
-             (install-file (string-append (assoc-ref inputs "automake")
-                                          "/share/automake-1.16/config.sub")
+             (install-file (search-input-file inputs
+                                              "/bin/config.sub")
                            ".")
 
              ;; Avoid dependency on "happy"
@@ -347,8 +347,8 @@ SplitObjs=NO
                (install-file "ghc/interpreter/nHandle.so" lib)))))))
     (native-inputs
      (list autoconf-2.13
-           automake
            bison                                  ;for parser.y
+           config
 
            ;; Needed to support lvalue casts.
            gcc-2.95