summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-09 08:49:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:45 -0400
commit04ed75cc9de4a8302ad1d168fb1b114a81a27a86 (patch)
tree371f8a4ed89a6f14894a450c6b41e65ca9feed4a /gnu
parentd6a716f9090a9ed953311cc3aa03b003222cefb9 (diff)
downloadguix-04ed75cc9de4a8302ad1d168fb1b114a81a27a86.tar.gz
gnu: libgnome-games-support: Update to 2.0.0.
* gnu/packages/gnome.scm (libgnome-games-support): Update to 2.0.0.
[propagated-inputs]: Remove gtk+; add gtk.
(libgnome-games-support-1): New variable.
(gnome-klotski)[inputs]: Replace libgnome-games-support with
libgnome-games-support-1.
* gnu/packages/games.scm (gnome-2048)[inputs]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/gnome.scm57
2 files changed, 39 insertions, 20 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 09ce55f168..3b05e0f88a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1789,7 +1789,7 @@ destroying an ancient book using a special wand.")
                (("gtk-update-icon-cache") "true"))
              #t)))))
     (inputs
-     (list gtk+ clutter clutter-gtk libgee libgnome-games-support))
+     (list gtk+ clutter clutter-gtk libgee libgnome-games-support-1))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin") ; for desktop-file-validate and appstream-util
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 469f7f04cb..66d84e27e2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6290,30 +6290,30 @@ queries upon that data.")
 (define-public libgnome-games-support
   (package
     (name "libgnome-games-support")
-    (version "1.7.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/libgnome-games-support/"
-                                  (version-major+minor version) "/"
-                                  "libgnome-games-support-" version ".tar.xz"))
-              (sha256
-               (base32
-                "11g1r3ppb9v8m3anks9gxf7fv1x38vmjiya3lr7zjjv328pb69d6"))))
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnome/sources/libgnome-games-support/"
+                           (version-major+minor version) "/"
+                           "libgnome-games-support-" version ".tar.xz"))
+       (sha256
+        (base32
+         "196jaga70r16bzypv4z07mnwr0xcm93gc91kxygcpp9fwdpiz0jk"))))
     (build-system meson-build-system)
     (arguments
-      '(#:glib-or-gtk? #t
-        #:phases
-          (modify-phases %standard-phases
-            (add-before 'check 'pre-check
-              (lambda _
-                ;; Tests require a writable HOME.
-                (setenv "HOME" (getcwd))
-                #t)))))
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests require a writable HOME.
+             (setenv "HOME" (getcwd)))))))
     (native-inputs
      (list intltool pkg-config vala))
     (propagated-inputs
      ;; Required by libgnome-games-support-1.0.pc
-     (list gtk+ libgee))
+     (list gtk libgee))
     (home-page "https://www.gnome.org/")
     (synopsis "Useful functionality shared among GNOME games")
     (description
@@ -6321,6 +6321,23 @@ queries upon that data.")
 GNOME Games, but it may be used by others.")
     (license license:lgpl3+)))
 
+(define-public libgnome-games-support-1
+  (package
+    (inherit libgnome-games-support)
+    (version "1.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnome/sources/libgnome-games-support/"
+                           (version-major+minor version) "/"
+                           "libgnome-games-support-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0zggsg7h9nlcwwjcqc13pdjza17iiww325r3q0d76f5hlw24chr8"))))
+    (propagated-inputs (modify-inputs (package-propagated-inputs
+                                       libgnome-games-support)
+                         (replace "gtk" gtk+)))))
+
 (define-public gnome-klotski
   (package
     (name "gnome-klotski")
@@ -6353,7 +6370,9 @@ GNOME Games, but it may be used by others.")
        ("vala" ,vala)
        ("xmllint" ,libxml2)))
     (inputs
-     (list gtk+ libgnome-games-support librsvg))
+     (list gtk+
+           libgnome-games-support-1
+           librsvg))
     (home-page "https://wiki.gnome.org/Apps/Klotski")
     (synopsis "Sliding block puzzles")
     (description