summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 22:58:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:11 +0300
commit04f813ec63de85e72becce40b625d6ebd0cd4484 (patch)
tree102248c7ac8c283a0a23508e0538294e3fdbd14f /gnu
parentfd305cd9600adc87599ea5a9aa70ec7eb0a5ac10 (diff)
downloadguix-04f813ec63de85e72becce40b625d6ebd0cd4484.tar.gz
gnu: python-natsort: Fix the test suite on slower machines.
* gnu/packages/python-xyz.scm (python-natsort)[arguments]: Add custom
phase to remove the time limit for some of the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e8763342f6..f7971b75fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18194,6 +18194,13 @@ JSON) codec.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'remove-test-hypothesis-deadlines
+           (lambda _
+             (substitute* "tests/test_utils.py"
+               (("from hypothesis import given")
+                "from hypothesis import given, settings")
+               (("( +)@given" all spaces)
+                (string-append spaces "@settings(deadline=None)\n" all)))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?