summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 22:40:01 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:18 +0800
commit08250bffab2ff09eb0dc12eaa39f4ecec3a9c3b5 (patch)
tree0ed5e65d8b6b1108d86784e1b6bb3bdaf430fac4 /gnu
parent27954c3cb2b771fdd9a8892fed45c1d675f434cc (diff)
downloadguix-08250bffab2ff09eb0dc12eaa39f4ecec3a9c3b5.tar.gz
gnu: Add python-slotscheck.
* gnu/packages/python-check.scm (python-slotscheck): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 3a718954c5..0ccae07093 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2023,6 +2023,31 @@ valid Python syntax that are likely to be commented out code.")
 behavior-driven development (TDD and BDD).")
     (license license:expat)))
 
+(define-public python-slotscheck
+  (package
+    (name "python-slotscheck")
+    (version "0.17.0")
+    (home-page "https://github.com/ariebovenberg/slotscheck")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference (url home-page)
+                                  (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0k5jjabd219ndlssfqcdb5sn891ffrxzw84l5r8pirzy74i7znr4"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-poetry-core
+           python-pydantic
+           python-pytest
+           python-pytest-mock))
+    (propagated-inputs (list python-click python-tomli))
+    (synopsis "Ensure @code{__slots__} are working properly")
+    (description
+     "@code{slotscheck} is a tool to validate Python class @code{__slots__}.")
+    (license license:expat)))
+
 (define-public python-stestr
   (package
     (name "python-stestr")