summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2018-04-25 19:51:38 +0300
committerAlex Kost <alezost@gmail.com>2018-05-02 19:28:44 +0300
commit0a287457d40bd35ab2af4f6068f4fb4ddb17bd37 (patch)
treebbb3c9bee1c92d7cc606269706965f742d76b405 /gnu
parentb225a3b837fe3367ff2115b84d64d408565916df (diff)
downloadguix-0a287457d40bd35ab2af4f6068f4fb4ddb17bd37.tar.gz
gnu: Add emacs-ghub.
* gnu/packages/emacs.scm (emacs-ghub): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5a3dd46586..c53a7f8e22 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -581,6 +581,37 @@ these arguments.  The prototypical use is for the command to call an external
 process, passing on the arguments as command line arguments.")
     (license license:gpl3+)))
 
+(define-public emacs-ghub
+  (package
+    (name "emacs-ghub")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/magit/ghub/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1zrb3xk04a228g2ahx0r02d0d3xskj60q73qavvmm2i56r66cxvc"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'make-info
+           (lambda _
+             (zero? (system* "make" "info")))))))
+    (native-inputs
+     `(("texinfo" ,texinfo)))
+    (home-page "https://github.com/magit/ghub")
+    (synopsis "Emacs client library for Github API and Gitlab API")
+    (description
+     "This package provides 2 files: @file{ghub.el} and @file{glab.el},
+which are the libraries that provide basic support for using the Github and
+Gitlab APIs from Emacs packages.  It abstracts access to API resources using
+only a handful of functions that are not resource-specific.")
+    (license license:gpl3+)))
+
 (define-public haskell-mode
   (package
     (name "haskell-mode")