summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-06-29 12:10:03 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-06-30 20:02:13 +0530
commit0ac042324af06a5d9877dd699bf778c3a794f5f9 (patch)
treeeb16fa27cc43c1da9d836539ffbd927af2ed06d3 /gnu
parentc97979d629df9197110f94d55c3e334858b7cf40 (diff)
downloadguix-0ac042324af06a5d9877dd699bf778c3a794f5f9.tar.gz
gnu: Add jo.
* gnu/packages/web.scm (jo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3625a1034e..e91bc1f13e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4674,3 +4674,24 @@ message stream (in a web server that is per connection).")
     (description "@code{httpretty} is a helper for faking web requests,
 inspired by Ruby's @code{fakeweb}.")
     (license l:expat)))
+
+(define-public jo
+  (package
+    (name "jo")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/jpmens/jo/releases/download/v"
+                           version "/jo-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0pysickpxrbl53c122h6swvz8sck68q3j0ql38wvbz70q9k4gvb3"))))
+    (build-system gnu-build-system)
+    (home-page "https://github.com/jpmens/jo")
+    (synopsis "Output JSON from a shell")
+    (description "jo is a command-line utility to create JSON objects or
+arrays.  It creates a JSON string on stdout from words provided as
+command-line arguments or read from stdin.")
+    (license (list l:gpl2+
+                   l:expat)))) ; json.c, json.h