summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 13:55:17 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 13:55:17 +0100
commit0b1f5d24776508283c636027cb3e887271cfbc63 (patch)
treea8a89e849c8bd5264ffdc06428515880799ba068 /gnu
parent063dfc56368c01a7c4c4944a3629257f632aab89 (diff)
downloadguix-0b1f5d24776508283c636027cb3e887271cfbc63.tar.gz
gnu: python-aws-xray-sdk: Set PYTHONPATH when running tests.
* gnu/packages/python-web.scm (python-aws-xray-sdk)[arguments]: Check:
Set PYTHONPATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 73a45ca4ca..78ef97fba6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -467,6 +467,8 @@ Model} (SAM) templates into AWS CloudFormation templates.")
                                   "tests/ext/aiohttp/test_client.py"))))
                   (replace 'check
                     (lambda _
+                      ;; Allow "import tests.utils" to work as expected.
+                      (setenv "PYTHONPATH" (getcwd))
                       (invoke "pytest" "-vv" "tests"))))))
     (native-inputs
      `(;; These are required for the test suite.